ZX Spectrum Build

Ask questions - discuss speaker building, testing, and related topics
mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

ZX Spectrum Build

Post by mpryfogle » Mon Apr 27, 2015 1:02 pm

I'm currently working through my ZX Spectrum build. I have the boxes built and am sketching out how I want to finish them. I ordered the kit from Meniscus but opted for Paul Carmody's 30 liter box design as opposed to the design from the instructions. A link to the gallery http://imgur.com/a/f1jIF

I am currently having issues as the speakers have 0 bass unless I crank the EQ from my receiver to full blast on the bass side. I've tested the woofers with a battery to verify that they are both in phase with each other and they do work. I have a large set of old Pioneer speakers in the room and the bass is normal sounding with those, while the ZXs currently have the bass response of a clock radio. This week I'll be working on debugging the bass issue. If anyone has suggestions, let me know.

** Update ** After playing for a bit, adding some polyfill and messing with the amp they have rounded out a bit, but are still very weak on the bass end. Much better than the clock radio, but not up to par for a decent set of bookshelf speakers, let alone small towers. If I turn the bass setting up to 8 (db?) then they sound much better.

Paul's design had an air core inductor for the woofer section while the kit came with an iron core inductor, I can't imagine this would make a huge difference but would it be advisable to change to the air core?

Paul Carmody
Posts: 4
Joined: Fri Mar 07, 2014 12:00 am

Re: ZX Spectrum Build

Post by Paul Carmody » Tue Apr 28, 2015 2:16 pm

Do you have another amp you can test them with? They should have a healthy amount of bass. What size port are you using? Are there any air leaks (aside from the port)?

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Tue Apr 28, 2015 4:17 pm

I've tested with a lepai 2020 with the same initial result, I'll verify again tonight as that was before I had added much padding.

There doesn't seem to be any air leaks besides the port, which isn't sealed in yet. The box is constructed with overlapping rabbets and the back, sides, top and bottom were also culked before the front was glued in in an attempt to reduce any chance of air leaks. I will check on leakage around the Neo3 tweeters tonight and attempt to verify that there isn't any leakage in that area.

Any other tips would be greatly appreciated.

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Wed Apr 29, 2015 9:51 am

I set up the speakers on the Lepai amp with a similar result.

The port is the 2" port with the 3.5" tube from the Meniscus kit.

I set up a few of the other speakers I have at the house http://imgur.com/a/plAJ0 and would say that the ZX has weaker bass than any of the 3. The large 4 way Pioneers are beasts on bass. The smaller 3 way Yamahas had a similar bass extension to the ZX, maybe a touch more but not a large amount.

Stand up bass on a jazz albums sounds extremely thin and unrealistic and bass drum often sounds like just the beater on plastic as opposed to a satisfying bass drum sound without some major EQ changes on the low end. I noticed that your schematics had air core inductors for the woofer as opposed to the iron core supplied from Meniscus and didn't know if this would make much of a difference. Mark at Meniscus told me that the Neo3s I received had their backs off but he glued them back on as they were the last ones he had, but the Neos haven't seemed to have any issue from what I can tell.

User avatar
Wolf
Posts: 182
Joined: Mon Feb 20, 2012 7:36 pm
Location: Indiana
Contact:

Re: ZX Spectrum Build

Post by Wolf » Wed Apr 29, 2015 10:49 pm

That doesn't seem right to me at all. Is it possible the polarity on one tower is reversed internally?
The Iron-core should have less DCR, and in fact, increase the bass output.

Wolf

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Thu Apr 30, 2015 9:22 am

I swapped the polarity of the tweeters, so positive to positive, ground to ground and it helped greatly. The tinniness is gone and bass instruments actually sound more like the actual instrument. The low end still seem to be lacking punch, but maybe I've just become too use to the monster pioneers with a hyped low end.

The sides of the box are lined with auralex pyramid foam and probably 5-6 oz per cabinet of polyfill. I've seen that that for a cabinet this size I should have closer to 9 oz per cabinet?

User avatar
Wolf
Posts: 182
Joined: Mon Feb 20, 2012 7:36 pm
Location: Indiana
Contact:

Re: ZX Spectrum Build

Post by Wolf » Thu Apr 30, 2015 11:22 am

I don't think that is better. This likely caused a suckout in the midrange that changed the tonality.
I'm wondering if the woofers are wired correctly, like just one might be out of phase.

Image

I would double check it against the schematic...

Later,
Wolf

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Thu Apr 30, 2015 11:04 pm

After work I pulled all the cables through the cabinet and verified where everything should go. I returned the tweeters to how they should be in the schematic and reassembled everything with no real improvement. Having the tweeters in the correct configuration does make the highs sound better and imaging is much improved, but the bass is still not there without cranking the EQ.

Running a sine sweep with an RTA on my iPhone (not the best for analyzing) and listening tests seem to show that while it is kind of audible below 60Hz, it's only barely and it doesn't start gaining enough amplitude until around 125 - 200Hz to really be heard in the mix. I've verified this by activating the EQ in iTunes and playing the same portions of several songs with the EQ flat and with 32 and 64Hz set to -12dB and was unable to tell which was which. Dropping the 125Hz was noticable.

User avatar
Wolf
Posts: 182
Joined: Mon Feb 20, 2012 7:36 pm
Location: Indiana
Contact:

Re: ZX Spectrum Build

Post by Wolf » Fri May 01, 2015 12:46 am

All the parts values in the schematic match and are in the correct positions?
If so- I don't know what the issue is.
Wolf

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Fri May 01, 2015 10:37 am

Thanks for the recommendations. I know how annoying it can be trying to debug someone's issues remotely, especially when they don't have a great amount of knowledge in the area.

The resistor going to the tweeter is 8.2 Ohm instead of the specified 8 Ohm, but I doubt that would have much effect on the woofer. I have the ground line running to the cross over -> woofer -> tweeter as opposed to having the tweeter also wired directly to the crossover. I know for most electronic applications this isn't an issue (save sensitive op-amps) but seeing as completely unhooked and from just one channel running the bass still seems weak, I didn't believe this to be an issue.

I'm contemplating ordering better quality crossover parts than what came in the kit and rebuilding the entire crossovers with what Paul has spec'd on his page as well as sealing behind the tweeter to stop any sort of air escape through that port.

From everyone's review of this speaker, I believe it's got bass hidden inside there somewhere and I've probably messed something up, but it would be really nice to be able to find it.

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Thu May 07, 2015 11:37 am

While working on these I sat on the floor (they're in a very tiny room currently) and was amazed that the bass response is much greater with my head at driver level or below. So I believe that most of my issues are probably in room layout and speaker location. I plan on raising them up a bit when they're complete so this shouldn't be as big of an issue.

They also seem to be gaining in bass response as the days go by, I'm not sure if this is a real phenomenon or if I'm just not listening to the bass heavy Pioneers as much and am getting use to something that is probably a more flat, true speaker.

I also added some extra sealing behind the tweeter and that might have helped a bit, but it could be psychological.

Thanks again for all your help,
Michael

Paul Carmody
Posts: 4
Joined: Fri Mar 07, 2014 12:00 am

Re: ZX Spectrum Build

Post by Paul Carmody » Wed May 13, 2015 12:04 am

I would suggest going to audiocheck.net and doing the "Loudspeakers Polarity Test." Do the "Rumble" and "Tone." Tests. Play their in-phase and out-of-phase versions of both. One of the two should be considerably louder than the other. If the out-of-phase version happens to be louder, then you know the polarity is flipped on one of your woofers.

mpryfogle
Posts: 9
Joined: Mon Mar 30, 2015 2:29 pm
Location: Knoxville, TN

Re: ZX Spectrum Build

Post by mpryfogle » Sat May 16, 2015 10:21 pm

I've got to say, these things sound awesome.

After sealing the tweeters in greatly and giving the woofers some time to break in I was getting some really deep bass and great highs, but the beater on a kick, snare hit and gain guitar lines were very thin. Tonight I swapped the phase on the tweeters opposite from what they are on the schematic and everything came to life. I'm not sure if these tweeters are somehow backward from what they should be, I was told they had their backs off before I got them, but these speakers are sounding amazing.

I've did some before an afters with Daft Punk, Tool, Miles Davis, Muse, the Beatles, mainly anything I had in my collection that had bass and I knew fairly well. For Daft Punk, these things are hitting like a truck. Incredible amounts of bass.

User avatar
Wolf
Posts: 182
Joined: Mon Feb 20, 2012 7:36 pm
Location: Indiana
Contact:

Re: ZX Spectrum Build

Post by Wolf » Sun May 17, 2015 11:53 am

If you have a smart phone, there are some RTA apps you can try to see if they are flat or non-flat in terms of response and likely answer your question about proper wiring. I would do one channel at a time, and then the pair. This is just to make sure.

Just a thought,
Wolf

stephenkatz9
Posts: 13
Joined: Tue Nov 19, 2013 7:42 pm
Location: Lima Ohio

Re: ZX Spectrum Build

Post by stephenkatz9 » Mon Sep 28, 2015 8:29 am

An easy way to check if one of your woofers has the wrong polarity: place the speakers facing each other a few inches apart, and see what the bass does. If it reinforces and gets louder they are in phase, if it disappears, the they are out of phase and therefore one of them has the wrong polarity.

Post Reply